Subform Rule Not Working

Comments

2 comments

  • Avatar
    Suhail Faisal

    Hi Taylor,

    I have tried replicating your use case. For me, it is working fine. I just wanted to know some more information from you for the below points before I can figure out the issue if it is.

    1) Please let us know your AgilePoint NX Version.

    2) The rules you are writing are at the control level and not at the form level.

    3) There are no cascading rules which work in the opposite way of your functionality.

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Taylor Howard

    Hi Suhail,

     

    I have one rule at the form level hiding the control unless certain conditions are met. Other than that, the rule says if United States (or one of the variations in my screen snip above), show the control and set it as mandatory. The controls in my screen snip are at the control level. I tried having them all as [this] or [*], and I made sure that the When piece said ANY and not ALL.

    I'm using AgilePoint NX v7.0.

    There aren't any cascading rules that interfere. The rules above are the only ones that impact this specific control.

    Thanks!

    0
    Comment actions Permalink

Please sign in to leave a comment.