Subform Wraps

Comments

9 comments

  • Avatar
    Gwen Wilson

    Hi Sylvia, change your Display Style to rows. Then you get more freeform placement. It will look more "form" like, and won't be a columnar grid look though.

     

    0
    Comment actions Permalink
  • Avatar
    Sylvia Able

    Thanks, Gwen.  The reason I don't like that display is that it doesn't give me the colored heading across the top...

    I could probably get by with the rows, but is there any way to squish the rows so that they are closer together and don't take up so much room?

    0
    Comment actions Permalink
  • Avatar
    Gwen Wilson

    I haven't found any changes that will work to alter the look. Even if you add more columns and try to space the fields that way, it seems to override that and give each field equal value (which is frustrating). There may be something with css that you can do, but that's a little outside my arena :)

    0
    Comment actions Permalink
  • Avatar
    Sylvia Able

    Yeah, I understand.  Its a little outta mine too.  ;)  I appreciate your quick responses!

     

    0
    Comment actions Permalink
  • Hi Silvia,
    As far as i remember you can click on the button choose fields to exclude... and there you can change the width of each column.
    Regards
    Alexey

    0
    Comment actions Permalink
  • Avatar
    Sylvia Able

    Thanks, Alexey...

    That doesn't work either.  But you have both pushed me to think about this a little more.

    If it is repeating, there must be only one row in the subform and when I unselect Repeatable, it appears to be wrapping all of the fields. 

    When I go into the Exclude Fields dialog, it lists all of my controls out....and even when I removed the Repeatable check mark, it still listed all of the fields:

    It actually seems a bit of a bug to me.  If I don't specify repeating, I would expect it to leave my fields where I put them on the subform; its odd.

    I appreciate you both responding!

    0
    Comment actions Permalink
  • Avatar
    Sylvia Able

    I started over from scratch with what I have learned and I believe Gwen was on the money.... I think if its not repeatable, you must use ROWS option.  It seems if you use the COLUMNS option, it expects that you are repeating and it treats everything that you have in the subform as one row...

    I appreciate you helping me get to this understanding!

    0
    Comment actions Permalink
  • Avatar
    Loren Bratzler

    Yes - the "Columns" display style generates the colored heading bar at the top which displays the field names.  In order for those headings to line up with the fields, the fields need to be in a single row.  Otherwise the headings would be stacked on top of each other.

    0
    Comment actions Permalink
  • Avatar
    Sylvia Able

    Thanks, Loren!

    0
    Comment actions Permalink

Please sign in to leave a comment.