REST API JSON validation

Comments

5 comments

  • Avatar
    AgilePoint NX Support

    Hello Nathaniel,

     

    If you have not changed anything in the REST activity configuration part and also not updated anything related to AgilePoint setup then we suspect that there might be a change in the GraphQL API behavior.

    Did you try using the same API and payload from a generic REST client like Postman or Advanced REST Client? Also, have you got in contact with the owners of the GraphQL API to see if there are changes from their side?

     

    Thanks,

    AgilePoint Support

    0
    Comment actions Permalink
  • Avatar
    Nathaniel Carter

    I am referring only to the behaviour of the Agilepoint interface. For example this query in simulation:

    Used to run perfectly and return JSON formatted data from said API. As you can see it, won't even let me attempt the query calling it an "invalid Request Body".

    0
    Comment actions Permalink
  • Avatar
    Alexey Shmelkin (ABSC.de)

    Hi Nathaniel,
    Between id and name should be : ? Perhaps AgilePoint expects there a valid json...

    Regards,
    Alexey

    0
    Comment actions Permalink
  • Avatar
    Nathaniel Carter

    Those 2 items are not a key/value pair they are requested fields from the API. 

    In the past it has responded with the data from the query as such:

    {"data":{"boards":[{"id":"438000992","name":"qdqwd"}]},"acount_id":5531818}

    0
    Comment actions Permalink
  • Avatar
    AgilePoint NX Support

    Hello Nathaniel,

     

    Can you try the same API and payload from a generic REST client like Postman or Advanced REST Client and share the observation to us. We do not have access to the product to Monday, so for the sample payloads which we tried with our set of API's, we are able to simulate and proceed next.

     

    Thanks,

    AgilePoint Support

    0
    Comment actions Permalink

Please sign in to leave a comment.